9 comments
Not resolved

The Shop Safe service is broken again. Clicking on "Shop Safe" generates a "system error" message. The Fia company has known about this bug for at least a week, and has not been able to get it fixed. To make matters worse, Fia recently removed the client version of Shop Safe, so customers have no choice but to use the broken Web version.

This has caused tremendous problems for me, and probably for other customers. A bug like this should have been fixed immediately.

My advice for anyone considering getting a Fia credit card: Find a different credit card that provides virtual card numbers.

Review about: Broken Service.

Review #541408 is a subjective opinion of a user.

1.0
Website
PRODUCT OR SERVICE Not specified
Reason of Review / Monetary Loss Damaged or defective / Not specified
Preferred solution Not specified

Had an Experience with FIA Card Service?

Submit review

Comments

Comment as anonymous or
Terms of Service
Post Comment
Cancel
mschloss

Appears to be back in service. We'll see for how long

Anonymous
Los Altos, California, United States #899443

As of this evening, it's working for me again!

Vic

I have the same problem.Called and in summary they said they knew about the problem, but no information on whether it's being worked on or an idea as to when it may be fixed.

As far as I can tell, the only fix is to get another credit card from a different company (City, or Bank of America). My FIA card is through Bank of America but apparently someone noted above that the Bank of America site works OK for shopsafe numbers. What really frosted me is they told me this is a free service.

They get a % of $ from all my purchases, which, in turn, raises the price of the items I purchase, so I indeed DO pay for it!Free, as if they are loosing $ on my purchases.

Anonymous
#893014

I am having the same issue.I have been repeatedly getting 'system error' when it hits 32% of loading the shop safe system for the past few days.

I normally use this program regularly and this is concerning.There is also no way to contact anyone specifically about the shop safe program!!!

Waiting
#892052

Still broken for FIA card on 10/28.Tech rep I reported it too acted like she'd never heard of it, and said she'd "turn in a ticket" and they'd get back to me in 5 days.

I didn't realize this is a recurring problem.Thanks.

SandyP
#889127

Google search revealed that others, including BOA customers, have been having the same problem.Their tech support is referring to it as the "32% problem" since the graphic loads until 32% is displayed at which point the "System Error" message is displayed.

I have the problem on a machine running Win 8.1 and another running Win 7, both with latest version of IE.

Have tried disabling virus and firewall, no joy.I reported the problem to tech support more than a week ago.

It's been "broken" for weeks!

Andy
to SandyP Farmington, New York, United States #939397

Customer service told me the same thing back in November.It's now february and the problem persists.

This has been happening for months.Pathetic.

Anonymous
#885328

It's broken for my FIA credit card, but it works fine for my Bank of America credit card ...

mschloss
#882860

Same problem.Rep told me that the ETA for a fix was November.

Ouch.

Love the benefits of the card.What other reasonable cards

have virtual card numbers?

You May Also Like